Novade Standard & Premium logo

Incident

Australia and France Server Upgrades

Resolved | Mar 12, 2026 | 11:35 GMT+08:00

Server outage was due to Microsoft Azure automated server updates performed during our scheduled update window.

Affected components

  • Australia Server
  • France Server

Monitoring | Mar 12, 2026 | 11:33 GMT+08:00

Server outage was due to Microsoft Azure automated server updates performed during our scheduled update window.

Status Page powered by Admin Labs